Navigation path

My rendition is not available

This document describes some common problems and how to solve them.

 

My document is not available

There are several reasons why a document might not be published as expected:

  1. The document is not in the expected state
  2. There was an error while rendering the document
  3. Other problems

These reasons are detailed below.

State related problems

The document might not be in the expected state. If you want to see your document in the live server your document must have the Active state. If your document is Active, you can skip this section.

If the document is not Active, and you did do the appropriate Promote or Power-Promote operation you should check the Task Status. The message there should explain, why the Promote failed; there might be a problem with the rendition (see the next session), or you might not have sufficient privileges.

Rendition related problems

It can take a while before a rendition is available if the server is very busy or if the rendition is very complex, but if your document is not available within a reasonable time there might be a problem with the rendition. To check if the rendition exist you can go to menu View and select View Renditions. If the rendition is not available there is probably an error in the XSL.

To see if the rendition generates an error you should go to menu Tools/Rendition and do a Checkout/Checkin. If there is an error you should be able to see the error cause in the 'All Messages' screen.

If there is no error logged, you should check if the document has a relation with an XSL file. You can do this via menu View/Associations/Presentations. Also check that the format attached is the format you expect and make sure that all languages are shown below the Locale header. If this is not the case you should reassociate the XSL and specify the correct format and select 'Use this presentation file for all translations'.



If there is an error you can find the associated XSL file in the same way. In this screen you can select the XSL file, do a Checkout, edit the XSL file locally and do a Checkin afterwards.